読者です 読者をやめる 読者になる 読者になる

File to import not found or unreadable: compass. in Rails 3.2.1

@import "compass"

Rails 3.2.1, compass 0.11.7 で compass を import しようとするとエラーになるので、Gemfile を以下のように書き換えると動く。

gem 'compass', :git => 'git://github.com/chriseppstein/compass.git', :branch => 'no_rails_integration'
gem 'compass-rails', :git => 'git://github.com/Compass/compass-rails.git'

compass 便利だけど、Rails のバージョンが上がるとすぐ動かなくなる印象がある。